This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: introduce SH 2a support

On Jul 29, 2004, "Stubbs, Andrew" <> wrote:

> I have not tested or checked this patch in detail, but there are two
> issues I notice straight off:

> 1) The inheritance tree is now badly broken.

> You have not updated the inheritance diagram in sh-opc.h so it is
> difficult to see exactly what you have done, but some analysis reveals
> the problems. This diagram was put in to try to make sense of the code,

I added a comment explaining what SH2a did.  I didn't have the energy
needed to update the diagram.  I was actually unsure as to what to do
about it.

> 	arch_sh4_up | arch_sh2a_up

> which introduces ambiguity when an instruction was introduced into two
> architectures independently

> The only solution is to invent one or more imaginary architectures (c.f
> sh3-nommu) in order to maintain a proper inheritance tree in which each
> and every instruction may be traced to a common ancestor.

Ugh.  Oh, well, I'll see what we can come up with.

> It looks like this new monster will cause some pretty nasty changes.

Yup.  I tried to warn you in advance about this upcoming part, but
unfortunately I couldn't share much information about it back then :-(

> Once this is properly resolved there will no longer be any need to
> always pass -isa=sh2a from the compiler


> I assume that, since you have added new test cases elsewhere, you have
> run the testsuite

I'm 100% sure I ran the assembler testsuite, because I know I had
failures in it that I had to fix before posting the final patch.  I'm
afraid I missed the linker testsuite, but I don't see any regressions
there either.  I see an ERROR compiling ld-sh/sh2.c, but IIRC it was
already there before.

That said, I don't see any evidence that the arch tests you mention
ran.  Do I have to do anything other than `make -k check-gas check-ld'
to get them to run?

Thanks for your feedback, it's very appreciated.  I'll try to get your
comments addressed as soon as possible.

Alexandre Oliva   
Red Hat Compiler Engineer   aoliva@{,}
Free Software Evangelist  oliva@{,}

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]