This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more information.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text] for building kernel


I used to build a toolchain for a target based on Pentium-M CPU.
The toolchain was built with no errors.

Then I tried to use this toolchain to build linux downloaded from with:
make ARCH=x86 CROSS_COMPILE=i686-unknown-linux-gnu-

I got an error message:
lx10010218:a99059(linux->make ARCH=x86 CROSS_COMPILE=i686-unknown-linux-gnu-
CHK include/linux/version.h
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-x86
CC kernel/bounds.s
In file included from include/linux/compiler-gcc.h:86,
from include/linux/compiler.h:40,
from include/linux/stddef.h:4,
from include/linux/posix_types.h:4,
from include/linux/types.h:14,
from include/linux/page-flags.h:8,
from kernel/bounds.c:9:
include/linux/compiler-gcc4.h:8:4: error: #error Your version of gcc miscompiles the __weak directive
make[1]: *** [kernel/bounds.s] Error 1
make: *** [prepare0] Error 2

According to include/linux/compiler-gcc4.h I should use a gcc version higher than 4.1.0

I used gcc 4.1.2 instead of 4.1.0 in the crosstool script and built. Then I rebuild the kernel. It worked fine.
I also tried to build with 4.1.0 and it worked. Somewhere between to the minimum minor version of
gcc was changed from 1 to 2.

Can you update the crosstool script ?


-- For unsubscribe information see

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]