This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

FIXED (sort of) Re: Setup cvs HEAD build problems

On Fri, 18 Oct 2002, Igor Pechtchanski wrote:

> Hi,
> Just checked setup out from cvs
> ( and tried to build.
> I created a new directory, from there ran "$(SETUP_SOURCE)/configure" with
> all the options listed on
> (except changing "gcc" to "gcc-2" and "g++" to "g++-2"), and then "make".
> I previously built setup from the distribution source ( on the
> same machine / software / package configuration with no problems.
> Here are some problems I've encountered with the cvs HEAD:
> 1) has direct calls for flex and bison.  I have byacc
> installed instead of bison, and configure found it and set YACC to it.
> When I changed the rule to use $(YACC) instead of bison, make was able to
> proceed.  I'm attaching a patch for that fixes it (it also
> uses $(LEX) instead of flex).
> 2) zlib doesn't build as checked out from cvs.  The reason is that the
> dependences are all screwed up.  Running 'touch aclocal.m4
> configure Makefile' in zlib fixed the dependences.  Oh, and it tried to
> rebuild all of them and failed, since I have CVSREAD defined, and the
> files couldn't be overwritten.  I'm not sure if there's a fix for this.
> Also, the autotools files in zlib were generated for an older version than
> is currently available, so the only way to regenerate them would be all at
> once...
> 3) I get a 'yylval not defined' when compiling  The exact
> message is:
> g++-2 -mno-cygwin -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"setup\" -DVERSION=\"0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBMINGW32=1 -DHAVE_ERRNO_H=1 -DHAVE_STRING=1 -DHAVE_STRING_H=1  -I. -I/usr/src/setup-cvs/setup -I/usr/src/setup-cvs/setup/bz2lib -I/usr/src/setup-cvs/setup/libgetopt++/include \
>         -I/usr/include/g++-3 -Winline -Wall -Wpointer-arith -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wcomments -I/usr/src/setup-cvs/setup/bz2lib -I/usr/src/setup-cvs/setup/libgetopt++/include -g -O2 -c -o inilex.o
> /usr/src/setup-cvs/setup/inilex.l: In function `int yylex()':
> /usr/src/setup-cvs/setup/inilex.l:50: `yylval' undeclared (first use this function)
> /usr/src/setup-cvs/setup/inilex.l:50: (Each undeclared identifier is reported only once
> /usr/src/setup-cvs/setup/inilex.l:50: for each function it appears in.)
> This is probably due to the differences between byacc and bison.  It would
> be nice if there was a mention somewhere that setup requires bison to
> build.  If that is indeed the case, though, please ignore the attached
> patch...
> I'll try installing bison and rebuilding tomorrow...  Sorry for the rant.

Well, problem #3 *was* due to the differences between bison and yacc - the
build completed with bison installed.  Apparently, iniparse.y is
bison-specific.  This also eliminates problem #1 as trivially false.
The setup homepage should mention bison, though.  I can provide a patch if
needed, although it'll probably be more effort to review it and change my
wording than to simply fix the webpage...

Problem #2 still stands -- one either needs to execute the appropriate
touch command, or watch his make fail, unable to write to aclocal.m4.  Not
sure what the fix should be.
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Water molecules expand as they grow warmer" (C) Popular Science, Oct'02, p.51

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]