This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ATTN: Apache, Perl, Python, and Exim maintainers

> Sorry for chiming in unannounced but the connection problem only seems to
> happen when libphp4 is loaded into the server. I have had a running Apache
> install (before I re-installed my production box) that worked for over two
> weeks. Add php to the equation and what died. Before 1.3.21 I
> was not even able to keep the daemon running longer than five minutes with
> or without php. Now it works perfectly by itself (without php).

nop, I see this happen even for a bare nacked apache without any extra

can you please issue the following to your httpd processes:

  $ /usr/sbin/ab -i -r 1000 http://localhost/

this will hit your apache with 1000 HTTP HEAD requests. After this has
done wait some seconds and re-do.

This should cause the httpd childs to 'hang'. And even a 'telnet
localhost 80' will either give you no TCP connect or if, you can enter
a HTTP request but will never get a response.

Ok, just to be sure: which cygwin version and OS are you running?


tolj at wapme-systems dot de
Wapme Systems AG

Vogelsanger Weg 80
40470 Düsseldorf

Tel: +49-211-74845-0
Fax: +49-211-74845-299

E-Mail: info at wapme-systems dot de
------------------------------------------------------------------- - wherever you are

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]