This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: mknetrel issues

On Sat, Jun 14, 2003 at 10:43:44PM +0100, Max Bowsher wrote:
>I've been trying to use mknetrel (natively on Cygwin) to build myself a
>I ran into a variety of small issues:
>1) This line:
>   sedit 's/^gcc_version_trigger[  ]*=.*$//' Makefile '*' :
>contains whitespace in the sed pattern. It's quoted here, but by the time it
>is actually used, the quotes have been lost by passing it to a shell
>function, producing the error "unterminated 's' command".

Can't explain.  Works for me.

>I'm guessing these are intended to be make variables, but the quotes are
>getting lost prematurely, and they are being interpreted by bash as $()
>command interpolation.

The parentheses should be dropped.  I never use these variables, so that's
why I never noticed the makefile-like usage.

>3) There seems to be a bug in extra/gcc: The addmakeflags GCJ=... GCJH=...
>does not take account of the fact that addmakeflags removes whitespace
>between its arguments, leading to the single flag of GCJ=...GCJH=... being

Can't explain.  Works for me.  I'll check in a fix which uses to
separate addmakeflags lines.  Maybe something changed since the last
time I ran mknetrel for gcc.

>I'm a little confused why all this is going wrong for me - given that
>mknetrel must obviously get regular use. On the other hand, I don't see what
>could be odd about my system to cause this.
>Can anyone (well, cgf, probably) explain any of this?

Nope.  Can't explain most of this.  Maybe since I run this on linux, that
explains things, otherwise I don't have a clue.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]