This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: mknetrel issues

Christopher Faylor wrote:
> On Sat, Jun 14, 2003 at 10:43:44PM +0100, Max Bowsher wrote:
>> I've been trying to use mknetrel (natively on Cygwin) to build myself a
>> gcc-3.3.
>> I ran into a variety of small issues:
>> I'm guessing these are intended to be make variables, but the quotes are
>> getting lost prematurely, and they are being interpreted by bash as $()
>> command interpolation.
> The parentheses should be dropped.  I never use these variables, so that's
> why I never noticed the makefile-like usage.

There is still something wrong with the quoting here:

Making net release for gcc-3.3-max, pid 2748
echo makeflags:  GCJ=i686-pc-cygwin-gcjGCJH=i686-pc-cygwin-gcjh
make[1]: Entering directory `/netrel/build/gcc-3.3-max/libiberty'
make[1]: *** No rule to make target `ASE_FLAGS_TO_PASS'.  Stop.
make[1]: Leaving directory `/netrel/build/gcc-3.3-max/libiberty'
make: *** [all-libiberty] Error 2

Since I don't understand what's supposed to happen, I'm going to avoid the
issue by removing all the needdevoflags stuff.

>> I'm a little confused why all this is going wrong for me - given that
>> mknetrel must obviously get regular use. On the other hand, I don't see
>> could be odd about my system to cause this.
>> Can anyone (well, cgf, probably) explain any of this?
> Nope.  Can't explain most of this.  Maybe since I run this on linux, that
> explains things, otherwise I don't have a clue.

Weird. Oh well, at least some thing got cleared up.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]