This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.5.5 package issue

A 1.3.x cmake would be able to work with a gcc for 1.3.x or
a gcc for 1.5.x.   I would suspect that there are folks out there that
have a cygwin install that has gcc that is not 1.5.x based.
For example, almost all the machines in my office are still
running 1.3.x with gcc and friends.   So, now if they want a new cmake,
they will also have to upgrade the compiler, cygwin, and most likely all
of the other packages they have installed just to get the new version
of cmake.  If I built the new version of cmake with 1.3.x, it would allow
cmake to be used by both the 1.5.x people, and the people that only want
to upgrade cmake and not all of cygwin. 

However, if new packages should be built with 1.5.x, I will build the new
package with 1.5.x.


>New packages should be built under 1.5.x.  What is a cmake good for,
>which runs under 1.3.x if gcc and friends only run under 1.5.x anyway?
>Corinna Vinschen                  Please, send mails regarding Cygwin to
>Cygwin Developer                      
>Red Hat, Inc. 

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]