This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.5.5 package issue

On Thu, Oct 02, 2003 at 10:23:26AM -0400, William A. Hoffman wrote:
>However, if new packages should be built with 1.5.x, I will build the new
>package with 1.5.x.

AFAIAC, it doesn't really matter.  If you want to use 1.3.22, that's ok
with me.  I don't see any reason to raise a hoopla about 1.5.x, though.
In most respects, it's no different than any other cygwin release.  I
suspect that if you built your application on 1.3.22 it probably
wouldn't run on 1.3.21, or some earlier versions of cygwin.  The big
difference between 1.5.x and 1.3.22 is the requirement for a __getreent
in 1.5.x created binaries.  The need for this symbol is unrelated to the
64 bit I/O changes in cygwin1.dll.

However, we haven't previously had people patrolling cygwin-apps looking
for released applications compiled under 1.3.1, so I don't see any
reason to start now.  HOWEVER, if we start seeing complaints about a
package which would be ameliorated by compiling the package under a new
cygwin, that would be cause to update the package to 1.5.x.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]