This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: HEADSUP: pcre security announcement

Hash: SHA1

According to Corinna Vinschen on 9/7/2005 2:26 AM:
> First a question to the maintainers in general:
> There's a dependency in pcre's setup.hint which pulls in the old libpcre
> which I created ages ago and which lacks versioning support.  I just
> checked and we don't have any package left which requires the old libpcre.
> Shouldn't we finally pull this crap from the distro?

I don't see any reason why new packages should depend on old libraries, so
it sounds fine to me if we quit supporting the old libpcre.

>>Here you go.  Since a lot of key programs (i.e. grep) depend on this,
>>please test and make sure that this doesn't break anything.


Since grep is in Base, and grep depends on libpcre0, shouldn't libpcre0
add Base to its setup.hint?  None of the other packages need to be in
Base, because they aren't needed on a bare-bones installation.

- --
Life is short - so eat dessert first!

Eric Blake   
Version: GnuPG v1.4.1 (Cygwin)
Comment: Public key at
Comment: Using GnuPG with Thunderbird -


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]