This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Setup 2.510.2.1 does nor work!

Bug reports for setup.exe should be sent to cygwin-apps@, not cygwin@. 
Please direct replies to cygwin-apps@.

Angelo Graziosi wrote:

> But it fails when 'parsing ini file': a popup window appears saying:
>     Application error: cygwin setup
>     The instruction '0x009501bd' has referenced the memory '0x9524aaf4'
>     The memory cannot be 'written'.
>     OK to terminate , Cancel to debug...

This one I'm not sure about.

>    Fatal error: uncaught exception
>    Thread: DialogProc
>    Type: 9Exception
>    Message: Package validation failure for
>    file://C:\cygwin\home\Administrator\....\release\X11\fontconfig\
>    libfontconfig-devel\libfontconfig-devel-2.2.2-1.tar.bz2
>    AppErrNo: 1

But this means that a file in your local cache has a size that does not
agree with setup.ini.  Check setup.log.full for details.  You should be
able to just delete the offending file.

I was not aware that any of this package validation code was touched
since the last version.  In any case, bailing on an invalid package is
not very friendly, so I will have to see if there is a better way to
handle it.  It will probably involve automatically deleting the cached


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]