This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ITA] gnupg-1.4.8-1

David Rothenberger wrote:
On 3/3/2008 11:47 AM, Gergely Budai wrote:
Package location:

This doesn't build for me, but maybe that's because I already have GPG installed? Only the tests fail.

Making all in checks
make[2]: Entering directory `/usr/src/gnupg/tmp/gnupg-1.4.8/.build/checks'
echo '#!/bin/sh' >./gpg_dearmor
echo "../g10/gpg --no-options --no-greeting \
--no-secmem-warning --batch --dearmor" >>./gpg_dearmor
chmod 755 ./gpg_dearmor
./gpg_dearmor > ./pubring.gpg < /usr/src/gnupg/tmp/gnupg-1.4.8/checks/pubring.asc
make[2]: *** [pubring.gpg] Error 57
make[2]: Leaving directory `/usr/src/gnupg/tmp/gnupg-1.4.8/.build/checks'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gnupg/tmp/gnupg-1.4.8/.build'
make: *** [all] Error 2

Details please! All I tried so far was

$ ./ all

and that build fine after adding Gergely Budai's public key into my
keyring. Yes, you need a cygwin gnupg installed to build it that way.

Did you use the build script from the source package?


P.S.: I also unpacked the freshly generated binary package after that
and gpg did the right thing during the few things that I tried.

PGP/GPG key  (ID: 0x9F8A785D)  available  from
key-fingerprint 550D F17E B082 A3E9 F913  9E53 3D35 C9BA 9F8A 785D

Attachment: signature.asc
Description: OpenPGP digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]