This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

minires-devel problem? (was: Re: [ITA] gnupg-1.4.8-1)

On 3/4/2008 9:12 AM, David Rothenberger wrote:
On 3/4/2008 12:10 AM, Gergely Budai wrote:
Do you have all the needed packages? (I test always in a fully
installed environment i.e. all cygwin packages installed).

I do not have all packages installed, but I believe I have all the dependencies to compile.

I tried running under strace and got the error:

"The procedure entry point __dn_skipname could not be located in the dynamic link library cygwin1.dll."

Does anyone else get errors like this?

Apparently not. I will try this again with a fresh install of Cygwin and/or another machine. The binary package works fine for me. I guess we should consider this to be a weird problem in my environment.

This worked fine for me with a fresh install.

The problem turned out to be my /usr/lib/libresolv.a. On my old installation, this was an archive. On a fresh installation, this was a symlink to /usr/lib/libminires.dll.a. It looks like the postinstall for minires-devel did not replace my existing /usr/lib/libresolv.a since it already existed.

David Rothenberger  ----

The first thing we do, let's kill all the lawyers.
                -- Wm. Shakespeare, "Henry VI", Part IV

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]