This is the mail archive of the cygwin-apps mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFU] ocaml-4.00.1-1

On 2013-06-07 07:31, Damien Doligez wrote:
wget -x -nH --cut-dirs=2 \
  $D/ocaml/emacs-ocaml/emacs-ocaml-4.00.1-1.tar.bz2 \
  $D/ocaml/emacs-ocaml/setup.hint \
  $D/ocaml/ocaml-4.00.1-1-src.tar.bz2 \
  $D/ocaml/ocaml-4.00.1-1.tar.bz2 \
  $D/ocaml/ocaml-base/ocaml-base-4.00.1-1.tar.bz2 \
  $D/ocaml/ocaml-base/setup.hint \
  $D/ocaml/ocaml-camlp4/ocaml-camlp4-4.00.1-1.tar.bz2 \
  $D/ocaml/ocaml-camlp4/setup.hint \
  $D/ocaml/ocaml-compiler-libs/ocaml-compiler-libs-4.00.1-1.tar.bz2 \
  $D/ocaml/ocaml-compiler-libs/setup.hint \

Ouch. Because of the fickle nature of OCaml's ABI, all OCaml libraries have to be rebuilt for every version bump. While there not be much OCaml code in the distro, I have dozens of libraries in Ports which need to be rebuilt. Next time, could you please give me some rebuild time before stabilizing a new version of OCaml?

Also, could you enable labltk? I haven't tried 4.00 yet, but 3.12 required this patch:;a=blob_plain;f=3.12.0-labltk.patch;h=f99bb84;hb=HEAD



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]