This is the mail archive of the mailing list for the cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

startxwin doesn't pop up a terminal

I've been using cygwin and cygwin/x or at least an
xterm by running the startxwin.bat provided by the
default cygwin setup.exe. (on windows xp)

Then I'm not sure what happened, I think I just
reinstalled some packages with setup, in any event,
when I now run startxwin.bat or if I try
or startx or XWin.exe, I don't get a terminal or
window pop up anymore. In th eprocess list there is an
XWin and an xterm (for startxwin), and there is an X
icon in the lower righ corner, but no window to type
into. I can only get the cygwin bash shell, which does
not provide graphics/x.

I tried to play with export DISPLAY=localhost:0 and
variants, and I tried to look for something simple
related to this issue on the FAQ, mailing list archive
or the web, or in the man page of startx.

When I run from the bash shell, it writes
a lot of lines. To me they seem to indicate that XWin
was launched, that some modules can communicate and
such. The last line is
winInitMultiWindowWM - Hello
and then nothing else happens.

I don't think I have modified anything in cygwin
compared to the defaults at download - in fact I just
reinstalled the x-parts, plus I don't know how to
modify anthing :-)

Am I just missing something small and simple? Where
can I find some instructions on how to (re)start using


Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]