This is the mail archive of the mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: DRI question

OpenGL is implemented on Cygwin/XFree86 in software.  The XFree86 port to
Mac OS X successfully tied the XFree86 GL layer to the Max OS X OpenGL
API... which in effect gave XFree86 on Mac OS X a DRI/hardware-accelerated
OpenGL implementation.  That could be done for Cygwin/XFree86, but it would
take a number of hours and it must not be useful to many people because no
one has done it yet.  Perhaps you guys at Boeing could work on it or you
could work out a deal with one of us (I would be interested) to implement
this feature for a fee (think fixed-price contract).  Let me know if you are
interested, or feel free to ask lots of questions if you decide to go it

Thanks for using Cygwin/XFree86,


> -----Original Message-----
> From: cygwin-xfree-owner at cygwin dot com
> [mailto:cygwin-xfree-owner at cygwin dot com]On Behalf Of Timothy Holt
> Sent: Tuesday, March 04, 2003 6:27 PM
> To: cygwin-xfree at cygwin dot com
> Subject: DRI question
> This is a Cygwin/XFree86 DRI question
> from:
>   Timothy A. Holt
>   Boeing, Seal Beach, CA.
> I down loaded Cygwin/XFree86 on Jan 21 2003
> onto a DELL x86-based PC for the purpose of
> compiling and running OpenInventor Programs.
> I got the OpenInventor built and compiled with
> their examples and my own code, but noticed
> that it wasn't using DRI hardware acceleration.
> I've been reading README.DRI and
> README.DRIcomp and tried some of the
> checks it said to do.
> xdpyinfo showed:
>   XFree86 version 4.2.0
>   but did not show XFree86-DRI extension
> glxinfo showed:
>   direct rendering: No
>   OpenGL renderer string: Mesa GLX Indirect
> My GL library is named libGL.a in the /usr/X11R6/lib
> when I do:
>   strings libGL.a | grep DRI
> I don't see any XF86DIR things...
> there are some _DRI_glxUseXFont
> kind of things.
> There is no XF86Config file any where,
> and no /usr/X11R6/lib/modules directory either.
> Question:  does this mean I need a different GL ?
> I thought that the XFree86 GL had the DRI.
> Do I have to do all these steps in README.DRIcomp
> to get DRI to work ?
> I'm a graphics programmer working
> most of the time on SGI UNIX workstations.
> We want to port some things to the PC; we
> have, using Exceed 3D, but would like to try
> with the Cygwin. My program runs with Cygwin
> now, but has problems with Z buffer, slow texture
> mapping, and sometimes slow to redraw window after
> resize or move. Also crashes when trying to popup the
> OpenInventor SoXtMaterialEditor from my program.
> Thanks for any help
>    tim

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]