This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: startx failure, on fresh install

You may want to use or startxwin.bat, since there seems to
be no evidence of anybody trying those methods yet.  My experience is
that I have tried startx and, and they both don't work; the
startxwin.bat file is the only one that worked for me.  Try it out, and
see what happens.

Thank you for the response. result seems identical to startx. startxwin.bat actually starts the server, but it's not viable:

(1) run startxwin.bat in win command shell. X appears in sys tray.
(2) "env DISPLAY= xclock & " in a cygwin shell: no window opens.
(3) "env DISPLAY= xlogo &" in a cygwin shell: X window opens,
but if you breathe on it, an error occurs (if you hit 'return' in the cygwin
shell, or if you just alt-tab to the X window and back). Error message is

Xlib: sequence lost (0x10000 > 0x32) in reply type 0x0!
X Error of failed request:  0
 Major opcode of failed request:  0 ()
 Serial number of failed request:  0
 Current serial number in output stream:  50

I can also run 'XWin -multiwindow' in a cygwin shell, and get a similarly flaky X session.

And the next time you report a problem, you might want to read:
Problem reports:

Well I did, actually; the full error dump is in the previous report that I linked to,
and there's even more info (from another user with an identical problem) in a report
linked to from there. I didn't think it was useful to replicate the full dump, I had no new information.

And, re putting my full address in: no sweat, I get so much spam already at this
address it's doubtful it will make any difference.

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]