This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

could not open default font 'fixed'


I'm sure you've all see this one posted on here before, but something
has to be different because none of the solutions that I have found
worked for me.

I've checked mount points ensuring directories existed.  I've
re-installed font packages.  I tried re-running the postinstall
scripts.  Yes, I have looked through the FAQ.

I've also verfied that the font.alias file in
/usr/X11R6/lib/X11/fonts/misc contained a 'fixed' alias.  I took that
and mapped it back to the actual .pcf.gz file an ensured it existed.
As far as I can tell, everything looks perfectly normal.

Except it won't start.

Here is the XWin.log:
(WW) /tmp mounted int textmode
_XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
(II) XF86Config is not supported
(II) See for more information
winAdjustVideoModeShadowGDI - Using Windows display depth of 16 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 1024 height: 768 depth: 16
winInitVisualsShadowGDI - Masks 0000f800 000007e0 0000001f BPRGB 6 d 16 bpp 16
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winMultiWindowXMsgProc - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to
lack of shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!

Fatal server error:
could not open default font 'fixed'
winDeinitMultiWindowWM - Noting shutdown in progress

Locating the 'fixed' font:

amacdona@amac /usr/X11R6/lib/X11/fonts/misc
$ grep ^fixed fonts.alias
fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1

From fonts.dir (I wasn't sure how to grep for
-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1, but
trust me it's there)

amacdona@amac /usr/X11R6/lib/X11/fonts/misc
$ ls 6x13-ISO8859-1.pcf.gz

I checked the cygwin setup.exe to see what version of X I had installed. Is there any issues with this particular version? I have for all the X packages. Well the ones that I have installed.

If anyone can help, it'd be much appreciated.
"When I do good, I feel good; when I do bad, I
feel bad, and that is my religion."
- Abraham Lincoln

"Things could always be worse; for instance,
you could be ugly and work in the Post Office
- Adrienne E. Gusoff

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]