This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

X11 apps failing after upgrade

All help gratefully received!  I haven't found this problem through
searches, apologies if I've been searching for the wrong terms.

In my first update in a few months I picked up the major upgrade to the
X server.  XWin -version now reports  After having the problems
below I did a full reinstall of Cygwin, with no success.

My symptoms look similar to tunneling via `ssh -X`, but it happens with
both `ssh -Y`, and when I do `xhost +` and display directly to
<server>:0 without ssh tunneling.  

My client machine is Solaris.  Everything worked fine before the update.
I'm running the installed startxwin.bat startup (with xterm REM'd out).

I can display xclock fine.  xterm appears up, but as soon as I hit a key
it crashes with:

  $ xterm
xterm:  warning, error event received:
X Error of failed request:  BadAlloc (insufficient resources for
  Major opcode of failed request:  136 (XKEYBOARD)
  Minor opcode of failed request:  16 (XkbSetNamedIndicator)
  Serial number of failed request:  117
  Current serial number in output stream:  130

During which, my /var/log/XWin.0.log gets 8 lines of:

GetWindowProp - pWin or name was NULL

I can't run GNU Emacs at all (self-built Emacs 22.3.1 on the client
Solaris machine, but I also tried 21.3.1 installed from,
same result):

  $ emacs
X protocol error: BadAtom (invalid Atom parameter) on protocol request
Fatal error (6)Abort (core dumped)

Nothing in /var/win/Xwin.0.log on that failure though.  I /can/ run the
local, Cygwin-installed GNU Emacs - kicked it off via the X server
system-tray menu.

Any suggestions gratefully received, including what other info I can
supply or what diagnostics can I run?

Since it seems nobody else is screaming about this suggests it's
something about my setup, but I can't think what.

On the plus side, I've now fixed my Emacs configuration to work better
in the terminal :).

Thanks in advance,


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]