This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [1.7] Socket problems after xorg-server update

Ken Brown wrote:
After I upgraded to xorg-server-1.6.0-10, XWin.exe exited immediately
with the following error message in the log file:

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6

Although it's clear as mud, this message should not be a fatal error, just a warning.

This is curious. I don't seem to have IPv6 installed and the server starts fine for me, with that warning.

You could try disabling the IPv6 socket with '-nolisten inet6' to see if it makes a difference.

Cygwin 1.7 adds IPv6 support, so the IPv6 support in xtrans is now turned on.
I guess there could easily be cygwin-specific problems with it...

After some googling, I decided that the problem might be that the IPv6 protocol wasn't installed. So I installed it, following the instructions at

Now XWin.exe works (except for two problems I'll describe below), but the log file contains

_XSERVTransSocketCreateListener: failed to bind listener
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for inet6

Could this still indicate a problem involving IPv6? Should I have done some configuration after installing it? I did run 'ipv6.exe if' and compare it to the output from a different machine on which IPv6 had been preinstalled. I didn't notice any substantial differences, but maybe I don't know what to look for.

The server probably hasn't been tested on cygwin with IPv6 enabled (certainly not by me) so you're breaking new ground :-)

It certainly should not require IPv6 to work.

Now for the two problems:

1. After running startxwin.bat, it takes about 20 seconds for the X icon to appear in the taskbar. I guess that's related to the socket problems reported in the log.

This is possible if it's trying some IPv6 address autoconf or something.

2. After I shut down the server by right-clicking the taskbar icon and choosing Exit, the files /tmp/.X0-lock and /tmp/.X11-unix/X0 don't get deleted.

I don't think this is a change from the previous version.

The lock file is used by creating a temporary file and trying to rename it to the lock file name (which is expected to fail if the lock file is being held open by another process), so leaving the old one around is tolerable (although may cause us some permissions problems if the server is next run by another user or something, which is why there is ...)

Two last bits of information:

First, while the X server was running, I gave the command 'netstat -b' and didn't see anything indicating a problem. Again, maybe I don't know what to look for.

Second, when I started XWin.exe, I didn't get the expected popup from the Windows firewall. (Maybe that's because the first time I tried it, it exited too quickly because of the missing IPv6.) I then tried to manually add the exception, but I get the message that the exception was already there. This surprised me, because I usually have to unblock a program each time a new version of the binary is installed.

I agree this is not normal.

Suggestions would be appreciated. I'm attaching cygcheck output, the XWin log, and partial output from 'netstat -b'. (The deleted portions don't involve port 6000.)

I guess in the first place I'd suggest you try adding '-nolisten inet6' and see if that makes a difference to your startup time, then uninstall IPv6 and see if you can start the server at all with that flag.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]