This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with new xinit - console window doesn't open (but bash starts)

More info:

If I run startxwin.bat from a CMD.exe command line, the bash console xterm opens just fine. I only have problems starting it from the shortcut.

I do see some interesting things in the log file, however:

MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shared memory support in the kernel

II) GLX: Initialized DRISWRAST GL provider for screen 0
[dix] Could not init font path element /usr/share/fonts/TTF/, removing from list!
[dix] Could not init font path element /usr/share/fonts/OTF/, removing from list!
[dix] Could not init font path element /usr/share/fonts/Type1/, removing from list!

Warning: Missing charsets in String to FontSet conversion

None of the compatibility settings are checked in the Windows shortcut.

I've attached the Xwin.0.log file

- Jim

On 11/19/2009 8:57 PM, Jim Reisert AD1C wrote:
I'm running the latest of everything Cygwin 1.7 (see below).

When I start the Xwin server from the Windows shortcut:

D:\Cygwin\bin\run.exe /usr/bin/startxwin.bat

I see a bash.exe process running, but no X window comes up, as per:

REM Make sure XWin is ready to accept connections before proceeding
%RUN% checkX -wait -d %DISPLAY% -t 12

REM Startup an xterm, using bash as the shell.
%RUN% xterm -e /usr/bin/bash -l

Anyone else notice this?

The problem is the same on my laptop at work running WinXP, as well as
my home system running Windows 7

- Jim

# cygcheck -c | egrep "cyg|x"

cygrunsrv 1.34-1 OK
cygutils 1.4.0-1 OK
cygwin 1.7.0-65 OK
cygwin-doc 1.5-1 OK
expat 2.0.1-1 OK
gettext 0.17-11 OK
libexpat1 2.0.1-1 OK
libexpat1-devel 2.0.1-1 OK
libpixman1_0 0.16.2-1 OK
libxcb1 1.4-2 OK
libXext6 1.1.1-1 OK
libxkbfile1 1.0.6-1 OK
libxml2 2.7.4-1 OK
lynx 2.8.5-4 OK
texinfo 4.13-3 OK
util-linux 2.14.1-1 OK
xauth 1.0.4-1 OK
xcursor-themes 1.0.2-1 OK
xemacs-emacs-common 21.4.22-1 OK
xinit 1.2.0-1 OK
xkbcomp 1.1.1-1 OK
xkeyboard-config 1.7-1 OK
xmodmap 1.0.4-1 OK
xorg-server 1.7.1-3 OK
xrdb 1.0.6-1 OK
xterm 250-1 OK

-- Jim Reisert AD1C, <>,

Attachment: XWin.0.log
Description: Text document

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]