This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

Re: Compiling Perl under b20.1

At 13:27 06/03/99 -0500, Charles Wilson wrote:

>BTW, did you apply the patch to a
>pristine copy of the source, or had you already applied the changes from Teun
>Burgers (below)?

No, from the pristine copy of course :) My perl is working quite right I
guess, I just wanted to help you controlling your build package, so I
started from the beginning, following your statements.

>'s the relevant part of Teun Burgers' post:

>> The configure script (relevant part in fhdr.old) creates
>> a script findhdr that looks for the header file. findhr first
>> simply tests for existance (test -f) of the .h file in
>> H-i586-cygwin32/i586-cygwin32/include and if not found there
>> it uses the C preprocessor gcc -E -.

>Except the script says "$usrinc/\$wanted" which fails for a different reason 
>on my system: $usrinc is a pathlist, not a single path. However, this
doesn't seem to
>cause a problem, because the second step works....


>The egcs-1.1.1 returns
>ude/stdarg.h" so the match succeeds. 

Oh yes, *NOW* I remember, I had the same problem, but read an article in
the list stated the egcs 1.1.1 fixed a similar problem. I upgraded to egcs
1.1.1 and that solved my problem. Therefore, I guess that this information
*definitely* need a place in your build instructions : egcs 1.1.1 might be

>However, the correction to the search regex will work in
>both cases.


>????. I understand the theory, but my build seemed to work okay.

egcs 1.1.1 :)

>However, I 
>don't see how including Mr. Burgers' fixes will hurt anything, so I'll go
ahead an 
>add them to the "patch", unless anyone can think of a good reason not to.

I tried, but was unable to find the relevant part to patch.

>> *) Furthermore, I'd just add that I had some problems while building perl
>> if source files were extracted in a binary mounted partition. BUT I also
>> read some testimony regarding the contrary (i.e. you need to mount it as
>> binary) ! Therefore, It's just a hint, but if you experience some problems
>> (sadly, I forgot to save the error messages), try different mount mode.

>I extracted into a binary mounted partition. My *guess* is that you might have
>used WinZip or somesuch to extract the source. If WinZip converted all 
>newlines to \013\010, AND the partition was mounted binary, then that
would cause problems.

Nope, I'm aware of the Winzip problem, and I'm taking care of that, by
systematically using tar / gzip :)

>> *) make test

(continuing in your answer to Earnie)

Sebastien Barre        

Want to unsubscribe from this list?
Send a message to