This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

Problem Building cygwin1.dll from January Snapshot

In an effort to get a version of cygwin1.dll that can be
redistributed with a GPLed program (including the source
of course) I've run into problems building.

I grabbed the cygwin-src-19990115_tar.gz tarball and
untarred it.  I ran configure in the toplevel and found
that it didn't seem to actually run configure in the winsup,
libiberty, and newlib directories so I went there and ran

When building everything builds fine until it needs libc.a
from libiberty.  I made sure it's built, but it seems to
not have been symlinked into the directory it expects it in.

I tried searching the archives but didn't find anything.

I've also tried looking on the web site but I must be missing

Are there instructions for building cygwin1.dll or is it a
case of "If you can't figure it out, you shouldn't be doing

I'll continue to look into it, but would appreciate any
information if someone else has run into this or has tips
on building cygwin1.dll.

Thank you,

Todd Goodman


Want to unsubscribe from this list?
Send a message to