This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

problem building egcs-1.1.2

I've been trying to build the egcs-1.1.2 binaries with
Mumit's patches applied to the source, but have so far been
unsuccessful.  The steps I've taken are summarized in
the short script appended to the end of this note (my 
cygwin package is installed in the `standard' place, 
ie, C:\cygnus\cygwin-b20).  

Following these steps (after an hour or so...) the build
ends in `Bootstrap comparison failure!', with *lots* of 
lines like:

alias.o differs
bitmap.o differs
c-aux-info.o differs
c-common.o differs
c-decl.o differs

The various environment variables (C_INCLUDE_PATH, etc)
have been set more-or-less on a trial and error basis
to eliminate errors at earlier stages in the build.  
Perhaps they're wrong, or perhaps I'm missing some...

I'm running NT4/sp3, with cygwin b20.1.  My DLL version
(from uname -a) is:

CYGWIN_NT-4.0 SUSY 20.1 (0.3/1/1) 1998-12-3 20:39:18 i586 unknown

Has anyone else attempted building egcs-1.1.2 with
Mumit's patches, and with what success?  I'm sure
that my problems stem from my implemtation rather
than from the patches.  Any feedback or suggestions 
would be appreciated.

cheers, Paul



export C_INCLUDE_PATH=$CYGTOP/include

tar -zxvf egcs-1.1.2.tar.gz
tar -zxvf egcs-1.1.2-x86-win32-patches.tar.gz
patch -p0 < egcs-1.1.2-x86-win32.diff

mkdir egcs-obj
cd egcs-obj
../egcs-1.1.2/configure \
  --prefix=/usr/local/package/egcs/1.1.2 \

make bootstrap-lean


   Paul Poffenberger          phone (250) 721 7741
   Dept of Physics            fax   (250) 721 7752   
   University of Victoria     email

Want to unsubscribe from this list?
Send a message to