This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: <defunct> processes under Win9x...

On Mon, Jun 05, 2000 at 01:26:55PM -0700, Ken Coleman wrote:
>I understand that this is difficult to debug from an strace log.  I was
>just hoping that the new information would spark some "a-ha!" in you
>that would make the fix easy :).  I'll be working on it more tonight,
>but for now I have a little more information.
>I'm attempting to attach to the process, and all I get is "Can't attach
>to process.".  I've attempted to run "gdb filename process-id", and
>done it within GDB with the appropriate commands.
>One other minor piece of the puzzle - Cygwin refuses to kill the
><defunct> process ID.  When I attempt this, it says:
> 1000  -1  13:22:30
> 1001   0  13:22:31 /usr/bin/BASH.EXE
> 1011   0  13:22:58 /USR/LOCAL/APACHE/BIN/HTTPD.EXE
> 1013   0  13:23:04 <defunct>
> 1014   0  13:23:06 /usr/bin/PS.EXE
>/usr/local/apache/bin $ kill -9 1013
>bash: kill: (1013) - No such pid
>/usr/local/apache/bin $ 
>I have also tried attaching to other processes, and it gives me the
>same error.
>Any thoughts?

You need to provide the Windows PID not the cygwin pid.

There isno guarantee, btw that the <defunct> process actually exists.
It actually shouldn't exist.  A defunct process is a process which has
a parent that exists that has not yet performed a "wait" on the child.


Want to unsubscribe from this list?
Send a message to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]