This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Problems compiling Vlib

I recently used the new setup.exe on a Win95 Laptop that I already had 
B20 installed to install the latest cygwin version.  I used the download 
from the Internet Option and then installed to an empty directory instead 
of replacing the B20 so I got the new (or what I believe to be new) 
Directory structure.  Seemed to install and work like a champ.  Since I 
was pretty new to cygwin when I installed B20 and am still new to it, I 
am really still checking it out.  The install and setup seemed to work 

I am however currently having problems the VGui Library by David Wampler 
using the makefiles which are included with the Vlib and I can't seem to 
determine where the problem is.  I tried to recompile under my old B20 
version but now that I installed the new net version and the new 
directory structure and it changes the mount points I can't get it to 
compile as a test under the old B20 version either.  I believe this is a 
mount point issue and was wondering if anyone can tell me what the 
default mounts were that were setup when you installed B20 so I can 
change my mounts when I run the old version to see if it will compile 

I thought it might be related to needing the mingw libraries or gcc2.95.2 
but I see gcc2.95.2 was installed with the net install and download the 
mingw extra's (gcc-2_95_2-mingw-extra_tar.gz) from and 
installed that to /usr/local/mingw and still get the same errors.

When I try to compile the V libraries either under the old B20 (with the 
incorrect mount points) or the new net version I get the following 

/usr/local/v/srcwin$ make vlib
g++ -c -I/usr/local/v/includew -I/usr/local/v/gnuwin32/include  -O2 -o 
/usr/local/v/obj/vapp.o vapp.cpp
vapp.cpp: In function `int CMain(void *, void *, CHAR *, int)':
vapp.cpp:1197: implicit declaration of function `int 
make: *** [/usr/local/v/obj/vapp.o] Error 1

I was getting a whole different set of errors but then I changed the 
mount for d:/cygwin to / from binmode to textmode and got it to this 
point.  This compile under the old B20 but I can't seem to get it to 
under the new.  And without the original default mount points for B20 I 
can't prove it did under B20.

Any insight in this would be greatly appreciated.

Brian Keener

This e-mail contains privileged and confidential information solely for the use of the addressee.  If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution, copying or other use of the message and its content is strictly prohibited.  If you have received this message in error, please notify use immediately by telephone or e-mail. 

Thank you.

Want to unsubscribe from this list?
Send a message to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]