This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

RE: [ Cygwin bash mount over Ataman telnetd is inaccessible.]

It's possible that this is a generic NT security problem that can show up
with services trying to do network access, depending on how the telnet
services logs a user into the system (I've never used Ataman myself).  It
would be helpful to know if access to the share was a problem from a
non-bash/cygwin environment.  It's also not mentioned, but I'm assuming that
the server on which the share is being accessed is also NT.

What may be happening is that the telnetd service is running under the
LocalSystem account, which means that it has no credentials for network
access (or to be more precise it has a Null set of credentials).  By default
that will mean it has no network access to remote machines, which are set up
by default (as of NT 4.0) to reject Null session credential clients, with
only a few exceptions.

I would normally expect that the Ataman service is requesting an interactive
login token for a user for authentication and then creating a process as
that user, which I would think would create the necessary network
credentials, but it also wouldn't surprise me to find out that it didn't :-)

One quick test would be to run the Ataman service as some specific user (it
can be set up that way in the services control panel).  The user selected
would probably need to be a full administrator (to ensure it can execute any
functions the telnet server may try when setting up a remote login).

The other approach is to try opening up (in general, or specifically) access
to the share in question on the server side for Null session clients (which
includes LocalSystem services):

You can either:

(a) Open up access in general for such clients, by installing beneath
    the registry key:
    the DWORD value:
        RestrictNullSessAccess = 0

    (The value is normally not present at all, but defaults internally to 1)

(b) Add either the existing share that the client is accessing (or perhaps
    dedicate a new limited share just for the client) and add that share
    to the value of NullSessionShares on the server (same key location).  It
    should already be present with a few entries.  Add your share as a new
    entry (if you use regedt32 it'll handle the REG_MULTI_SZ type nicely).

You'll have to restart the server (or at least the LanmanServer service) for
changes to take effect.

Neither of these are necessarily that attractive as a long term operating
solution, but may at least be useful in the test environment.

-- David

 \               David Bolen            \   E-mail:  /
  |             FitLinxx, Inc.            \  Phone: (203) 708-5192    |
 /  860 Canal Street, Stamford, CT  06902   \  Fax: (203) 316-5150     \

-----Original Message-----
From: Chris Faylor []
Sent: Monday, June 12, 2000 11:36 AM
Subject: [ Cygwin bash mount over Ataman telnetd is

Can anyone offer any help to this guy?


----- Forwarded message from Mike Melendez <> -----

From: Mike Melendez <>
Subject: Cygwin bash mount over Ataman telnetd is inaccessible.
Date: Mon, 12 Jun 2000 11:11:19 -0400

I am attempting to use the same Expect script to automate internal tests
a BSDI system to Solaris, Linux, and Windows NT.  For NT I am using:
     Windows NT 4.0 (Build 1381: Service Pack 5)
     Cygwin 1.0 bash shell
     Ataman TCP Remote Logon Services 2.4 simple telnet

In a bash shell on the desktop and through the Ataman telnetd as the same
I can successfully
     $ mount \\\\<server>\\<directory> <mount-directory> or
     $ mount Z: <mount-directory>

However, only on the desktop can I access the remote directory through the 
mount directory.  Through the Ataman telnetd, attempts to cd
return: "bash.exe: cd <mount-directory> : Permission denied"

I have tried this with system mounts (mount -s) as well as local mounts and 
both with and without a desktop user simultaneously logged in -- all with
same result.

Robert Michael Melendez
Orca Systems, Inc                781-895-4949 x227

----- End forwarded message -----

Want to unsubscribe from this list?
Send a message to

Want to unsubscribe from this list?
Send a message to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]