This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

SSHD problem in NT

Hi all!

I have a problem with sshd on my NT

Environmennt :

C:\etc\passwd :

C:\local\sbin\opensshd\conf\sshd.conf :
Port                    22
Protocol                1
HostKey                 c:/local/sbin/opensshd/conf/sshd_host_key
HostDSAKey              c:/local/sbin/opensshd/conf/sshd_host_dsa_key
PidFile                 c:/local/logs/opensshd/

#AllowUsers              Administrator

PasswordAuthentication  yes
PermitEmptyPasswords    yes

KeepAlive               no
PrintMotd               yes
CheckMail               no

IgnoreRhosts            yes
IgnoreUserKnownHosts    yes
RhostsAuthentication    no
RhostsRSAAuthentication no

sshd -d -f \local\sbin\opensshd\conf\sshd.conf :
debug1: sshd version OpenSSH_2.3.0p1
debug1: Seeding random number generator
debug1: Seeding random number generator
debug1: Bind to port 22 on
Server listening on port 22.
Generating 768 bit RSA key.
debug1: Seeding random number generator
debug1: Seeding random number generator
RSA key generation complete.
debug1: Server will not fork when running in debugging mode.
Connection from port 2359
debug1: Client protocol version 1.5; client software version OpenSSH-1.2.3
debug1: no match: OpenSSH-1.2.3
debug1: Local version string SSH-1.5-OpenSSH_2.3.0p1
debug1: Sent 768 bit public key and 1024 bit host key.
debug1: Encryption type: 3des
debug1: Received session key; encryption turned on.
debug1: Installing crc compensation attack detector.
debug1: Attempting authentication for Administrator.
Failed password for Administrator from port 2359

ssh -v :
SSH Version OpenSSH-1.2.3, protocol version 1.5.
Compiled with SSL.
debug: Reading configuration data /etc/ssh/ssh_config
debug: Applying options for *
debug: ssh_connect: getuid 1000 geteuid 1000 anon 1
debug: Connecting to [] port 22.
debug: Connection established.
debug: Remote protocol version 1.5, remote software version OpenSSH_2.3.0p1
debug: Waiting for server public key.
debug: Received server public key (768 bits) and host key (1024 bits).
debug: Host '' is known and matches the host key.
debug: Encryption type: 3des
debug: Sent encrypted session key.
debug: Installing crc compensation attack detector.
debug: Received encrypted confirmation.
debug: Doing password authentication.
Administrator@'s password:
Permission denied, please try again.

If I'm changed the line in sshd.conf from 
#AllowUsers        Administrator
AllowUsers        Administrator

then the error message :
debug1: Attempting authentication for illegal user Administrator.
Failed password for illegal user Administrator from port 2836

Please help me :what (or where) is the problem in my machine ?

PermitEmptyPAssword is yes, but it isn't work with or without password too.

How to set up a correct passwd,sshd.conf or any files ?

Thanks in advance!


Want to unsubscribe from this list?
Check out:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]