This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Connection immediately closed after sucessful login.

An earlier version of  message was also sent to Mike erdeley's sshd list.

Server Platform Win2K pro (workstation).

Cygwin 1.3.8-1
Openssh 3.0.2p1

Client Platform Linux 7.1

Gave group SYSTEM the following 4 additional privleges:
	Act as part of the Operating sytem
	Logon as a Service.
	Replace process level token
	Increase Quotas.

printenv | grep CYGWIN
CYGWIN=ntsec tty binmode

Ownership of /etc/ssh* is SYSTEM, SYSTEM mode 600.

Setting up a shell in accordance with Sshd Testing page
(useful trick, but it took me a long while to find the
instructions for the regedit that goes with using srvany)

If I run either version of sshd in that window (I tried
recompiling from source into /opt/openssh) I get the same

It finds the user keys, seems to find them satisfactory,
then it finishes with:

debug2: callback done
debug2: callback start
debug1: session_by_channel: session 0 channel 0
debug1: session_input_channel_req: session 0 channel 0 request shell reply 0
debug1: channel 0: rfd 7 isatty
debug1: fd 7 setting O_NONBLOCK
debug1: fd 3 setting O_NONBLOCK
debug2: callback done
Read error from remote host: errno ESHUTDOWN triggered
debug1: Calling cleanup 0x414208(0x4aa644)
debug1: session_pty_cleanup: session 0 release /dev/tty3
debug1: Calling cleanup 0x41eba4(0x0)
debug1: channel_free: channel 0: server-session, nchannels 1
debug3: channel_free: status: The following connections are open:
  #0 server-session (t4 r0 i1/262 o16/0 fd 7/3)

debug3: channel_close_fds: channel 0: r 7 w 3 e -1
debug1: Calling cleanup 0x416a4c(0x0)

On the client end,
debug1: next auth method to try is publickey
debug1: try pubkey: /root/.ssh/id_rsa
debug1: input_userauth_pk_ok: pkalg ssh-rsa blen 149 lastkey 0x80ff170 hint 1
debug1: read PEM private key done: type RSA
debug1: ssh-userauth2 successful: method publickey
debug1: channel 0: new [client-session]
debug1: channel_new: 0
debug1: send channel open 0
debug1: Entering interactive session.
debug1: client_init id 0 arg 0
debug1: channel request 0: shell
debug1: channel 0: open confirm rwindow 0 rmax 16384
debug3: Trying to reverse map address
Last login: Wed Jan 23 12:54:33 2002 from
You are successfully logged in to this server!!!
Connection to cycl-241 closed by remote host.
Connection to cycl-241 closed.
debug1: Transferred: stdin 0, stdout 0, stderr 79 bytes in 8.3 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 9.5
debug1: Exit status -1

Note: There is about a 3 second pause between sucessfully logged in
notice and connection closed.

Note also that this rather short session updates the lastlog file,
but does not execute my .bashrc file.

If I set PubkeyAuthentication to no, I get a password prompt
and that works. Interactive session.  However I need the
passwordless authentication to work so that I can force reboots
on a cluster of machines.

Ideas on what I've missed?

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]