This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Having problems running services under Win2K ( inetd/sshd/... )?

Over many frustrating hours I have been trying to get inetd ( or sshd ) to
work with my Win2K cygwin setup to enable civilized remote access.  It
worked great on one of my local systems, but every time I tried to start the
service on a very similarly configured machine it would fail with:

cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062: 
The Service has not been started.

Searches of this mailing list and extensive google searches were no use.
Ultimately I found the culprit.  For some reason setup.exe had created all
of my root mount points as user mounts and not system mounts.  Therefore the
service when started as user: SYSTEM couldn't find, well anything, and
failed without printing any useful status.  The solution is to change / from
a user mount point to a system mount point.

I hope this description saves someone else the headache.



Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]