This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Minimum Install for Executable Distrubution

* Max Bowsher (03-02-25 00:25 +0100)
> Thorsten Kampe wrote:
>> * Max Bowsher (03-02-24 23:50 +0100)
>>> Thorsten Kampe wrote:
>>>> * Charles Krug (03-02-24 23:38 +0100)
>>>>> We've built the gcc/as/ld toolset as a cross compiler to the
>>>>> Altavec PowerPC.  We've been using it internally for a couple of
>>>>> weeks.
>>>>> Those of us with full developer Cygwin installations can run the
>>>>> program with no problems.
>>>>> We'd like to be able to distribute a minimal package to everyone
>>>>> here who needs the cross compile capability.
>>>>> [Detailed stuff]
>>>>> I BELIEVE the correct course of action would be to do a default
>>>>> Cygwin install
>>>> Not "default", but "Base".
>>> Since "default" is "Base", there's little point in distinguishing.
>> If I remember correctly, there are quite a few packages in the default
>> install that don't belong to the Base category. The Base packages
>> might depend on those, so I may be wrong.
> OK, strictly speaking, default is Base plus any extra packages dragged in my
> dependencies (and yes, there are a few).

I checked it myself and I was wrong: the default install is exactly 
the base install (plus dependencies) and this is exactly the minimum 

 Content-Type: text/explicit; charset=ISO-8859-666 (Parental Advisory)
 Content-Transfer-Warning: message contains innuendos not suited for
 children under the age of 18

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]