This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: exim 4.12-3 winsock problem (was Re: 1.3.21)


On Tue, Feb 25, 2003 at 12:43:31PM -0500, Pierre A. Humblet wrote:
> Jason Tishler wrote:
> > The above fixed the problem.  I apologize for not being able to
> > figure this out myself.
> Actually I'd rather have you hit this problem than almost anybody
> else.  Figuring out what was happening without accurate strace output
> took some doing.

Thanks for your gentle treatment and kind words. :,)

> Can you invest a little more time and try to understand why wsock
> doesn't start without it (e.g. lookup how privileges are assigned on
> your system)? I'd like to detect the bad situation and log a warning. 

I tried adding a group:mail:r-x ACL to the following:


but I still failed in the same way.

Any other suggestions of where to poke and prod?

> > I'm not:
> So let me rephrase the question: is there a particular reason why you
> have defined an exim user (in addition to having a mail group for
> deliveries, I know that makes a lot of sense). 

Not really -- it may just be "historical".  Remember, I started with
your 4.02, upgraded to my private 4.10, upgraded to your 4.10, and now
upgraded to your 4.12.  IIRC, some doc recommended running as a user
other than root (i.e., LocalSystem).  It seems safer to do so unless
really required.


PGP/GPG Key: or key servers
Fingerprint: 7A73 1405 7F2B E669 C19D  8784 1AFD E4CC ECF4 8EF6

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]