This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: cygwin archive? (previous versions for fallback)

I can't access the site by typing the URI
e) into the installer. It timed out. I downloaded the whole tree.

That won't install either. The installer throws a fit (aka. an address
exception) after showing strange chars in the install tree root and only a
few leaves.

Okay, so I installed the latest and greatest complete cygwin WITHOUT
Postgres, installed the ipc-daemon (I can't get the one I had, so it's 1.13.
I installed, got the usual (at least on my machine) mode 0000 for all
binaries (?). Chmod'ed them to 2777 (I know that's unsecure).
--install-as-service'd the ipc-daemon and verified that it ran.

Started the installer from the cygwin site and thanks to the advise from
Christopher (PolleyChristopherW at JohnDeere dot com , thank you very much!)
installed from the copy of the tree ftp'ed from the site the Postgres (V

When I pg_start'ed Postgres it took 99% cpu; the usual sign that it does not
find the ipc-daemon. I verified that the daemon ran. (It did). Chris send me
a copy of 7.2.3 (identical to the version I had before). I installed from
this version after completely uninstalling and physically removing the
cygwin directory tree:
	Same result.

Lastly I reinstalled with the latest version of postgres and voila, it ran
like a pink rabbit. Uninstalling Postgres and installing any of the two
prior versions resultet in 99% cpu from Postgres.

My conclusion is that the ipc-daemon is the culprit and not backwards
compatible to Postgres < 7.3, which does not make a whole lot of sense.

There is NO version 1.10 of cygipc aka. ipc-daemon on available for

Does anybody out there have either V1.10 of cygipc or a glue what is going
so wrong with my install?

-----Original Message-----
From: cygwin-owner at cygwin dot com [mailto:cygwin-owner at cygwin dot com] On Behalf Of
Max Bowsher
Sent: Sunday, March 09, 2003 4:46 AM
To: günter strubinsky; cygwin at cygwin dot com
Subject: Re: cygwin archive? (previous versions for fallback)

günter strubinsky wrote:
> I had a previous release of cygwin running. It contained postgresql
> 7.2.3. When I updated now, Postgresql version 7.3.2 was installed
> which sadly requires a dump and restore of the 'old' database to
> recognize the data. That I found out too late. My data can not be
> accessed anymore. When I tried to download a previous version via
> installer, the only version accessible is
> 7.3.1 which doesn't go back early enough.
> I need to go back to a version that contains PostgreSQL 7.2.x or my
> data is lost.
> I don't mind that the installer doesn't warn of release changes which
> renders your data inaccessible, but I NEED to be able to go back
> (only to dump my data so that it can't be reloaded with the brandnew
> version.
> There must be a way to access an archive of 'older' cygwin
> installation packages.

One previous version, and that is *all*!

Now, you happen to be in luck, since there was recently discussion about a
mirror that seems to have stopped updating a month ago.

still contains 7.2.{1,2,3}

I emphasize this is pure *luck* that this mirror seems to have broken at a
convenient time to save you a lot of trouble.


Unsubscribe info:
Bug reporting:

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]