This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCEMENT] New release of setup.exe (

Pierre A. Humblet wrote:
On Thu, Mar 13, 2003 at 11:45:58PM +0100, Markus Schönhaber wrote:

Thanks a lot for the report, Markus.

You're welcome. Guess, your reply reached me and not the list because I forgot to set the Reply-To: field correctly. Sorry.

Did a fresh install at my XP-Prof box at home - moving the directories and registry keys out of th way beforehand. I just now realize, I forgot to remove the CYGWIN environment variable. Don't know if this has any influence on the installation process.

Only possibly in postinstall scripts, if they do not set it.

Seems to me that almost everything has worked fine (haven't intensively tested though). Just, when the postinstall script ran, I was able to read a message saying that the domain controller wasn't found. Seems to me, this message came from mkpasswd (is it called with the -d param in postinstall?).

Sorry about that, see <>
Your mirror seems to be updated slowly.

No problem. There are some more boxes waiting to get updated (domain members / standalone workstations). I'll do that next week. Propably then my mirror will carry the most recent files.

Read/execute permission was set for owner and group (Users) for all files in /bin. So i guess the problem of bash not finding some executables when logged in with other credentials should be gone now. Most files seem to have no permission for "other"s.

Great. Note that setup.exe respects the inherited access rights definedon your system (where Everyone apparently has no access). Only the *display*
has been improved.

Exactly: No ACE for Everyone. Thanks for clearing that up.

Since I did the installation logged in under an administrator account there wasn't any need for setup to ask wether it should run as Administrator - and it didn't ask.

Too bad :( This behavior has only been reported a few times, I'd like
to understand it!

The way setup behaved is exactly the way I expected it to and the way I
would consider right. But you seem to consider this a problem. Obviously I
did miss the point here - maybe we are talking about different things.
It's not about the "Select Root Install Directory" dialog where you can
select to install for "All Users" or "Just Me", is it?
I just started setup under a non-privileged account and XP's mechanism to show the "Run as Administrator" dialog when starting a program called "setup.exe" or "install.exe" kicked in.
Maybe this is what you meant? If so - it worked for me.


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]