This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCEMENT] New release of setup.exe (

Markus Schönhaber wrote:
> Pierre A. Humblet wrote:
> > Markus Schönhaber wrote:
> >>I just started setup under a non-privileged account and XP's mechanism to
> >>show the "Run as Administrator" dialog when starting a program called
> >>"setup.exe" or "install.exe" kicked in.
> >>Maybe this is what you meant? If so - it worked for me.
> >
> >
> > Yes, that's it. You seem to be very familiar with it.
> > Where is it documented? Is it language dependent?
> >
> No, I'm not too familiar with it. I just know that it has been there when
> I expected it to be.
> Have quickly looked into the MSDN Lib and found nothing. So getting the
> exact specification will take some research.
> Here are some unproven opinions of mine (beware! yet to be verified):
> - Since setup.exe triggered this mechanism on a German windows, I doubt
> that this feautre is language-dependent.
> - To work properly, I think this feature relies on the secondary locon
> service (Run As service in W2k?). So if the dialog doesn't appear on some
> machine - even though the user has *not* at least power user rights - the
> first thing I'd check is wether the secondary logon service is running.
> - As mentioned above, I seem to remember that the dialog will not appear
> if you are power user or administrator (to me only the latter was obvious).
> > The main question is: what's the group of the files (Users or Administrators)?
> > If it's Administrators and Everyone does not have access, then most normal
> > users probably don't have rx access.
> >
> The Group is Users. Seems OK to me.
OK, thanks for the information, Markus. 
So far so good.

I recall another problem that somebody had reported after answering "yes".
The chown command in a postinstall script had no effect. That would mean
that at, at least at that site, the program was lacking the Restore privilege.
To test if this is a prevalent problem, a simple test is to put a script in /etc/postinstall . setup will then run it and we can
see if the command worked.


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]