This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [ANNOUNCEMENT] New release of setup.exe (

Pierre A. Humblet wrote:
Markus Schönhaber wrote:

Pierre A. Humblet wrote:

Markus Schönhaber wrote:

I just started setup under a non-privileged account and XP's mechanism to
show the "Run as Administrator" dialog when starting a program called
"setup.exe" or "install.exe" kicked in.
Maybe this is what you meant? If so - it worked for me.

Yes, that's it. You seem to be very familiar with it.
Where is it documented? Is it language dependent?

No, I'm not too familiar with it. I just know that it has been there when I expected it to be. Have quickly looked into the MSDN Lib and found nothing. So getting the exact specification will take some research.

I have done some more research now but it seems the exact specification is
buried somewhere where at least I can't find it. Nevertheless I have found
some potential reasons for the "Install Program as other User" dialog not
appearing. In the W2k Group Policy Reference there are two pages related
to this:
describes how to turn off this feature using group policy, while
explains how to enable it even for network shares.
There is (as always?) a registry entry related to the Group Policy:
(should check for Microsoft's documentation regarding this point - but I beleive him)

There is also a knowledge base article with the same info:
Just loosely related but also interesting:

This clearly doesn't answer your questions where this feature is documented and whether it is language dependent but it hints at two more spots to look at when it's not working:
- it might be turned off by Group Policy or the corresponding registry value,
- setup.exe might reside on a network share meaning that the "Install..." dialog won't show up by default (could verify that behaviour on my machine).

Here are some unproven opinions of mine (beware! yet to be verified):
- Since setup.exe triggered this mechanism on a German windows, I doubt
that this feautre is language-dependent.
- To work properly, I think this feature relies on the secondary locon
service (Run As service in W2k?). So if the dialog doesn't appear on some
machine - even though the user has *not* at least power user rights - the
first thing I'd check is wether the secondary logon service is running.
- As mentioned above, I seem to remember that the dialog will not appear
if you are power user or administrator (to me only the latter was obvious).

The main question is: what's the group of the files (Users or Administrators)?
If it's Administrators and Everyone does not have access, then most normal
users probably don't have rx access.

The Group is Users. Seems OK to me.

OK, thanks for the information, Markus. So far so good.

I recall another problem that somebody had reported after answering "yes".
The chown command in a postinstall script had no effect. That would mean
that at, at least at that site, the program was lacking the Restore privilege.
To test if this is a prevalent problem, a simple test is to put a script in /etc/postinstall . setup will then run it and wecan
see if the command worked.

I'll check that out. But you'll have to explain that to me in clear and simple words, that even I am able to understand what I am supposed to do.


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]