This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Hate to say it, but...I've got the (dreadded) PID problem

Hate to say it, but...I've got the (dreadded) PID problem

Hello everyone,

I haven't been here in a while as my main computer died and I was
practically Cygwin'less. I have just finished a fresh install of Windows
2000 Pro/SP3 with all of the latest cygwin bits (that I need) which is
running 1.3.22 . I'll get to the point...While fixing the permissions on my
installation (via a combination of `find -exec' and `chmod'), and when I say
while I mean pretty much straight away, I started getting tones of "Access
is denied" messages from find. Sure enough I couldn't do anything from my
shell. I hate to say it but I can't do much with cygwin now (need to build a
lot of tools) as after running a few fork()ing processes I get an "Access is
denied" message from the binary that's being executed.

I've attached the output of `cygcheck -svr' and the strace output. I don't
want to sound like I'm bitching about this, really I'm not :-) If there's
anything I can do to provide info please ask.

I've done some investigating, attached to the offending process (bash) with
strace, and tried a few things. From a DOS (cmd.exe) box I can run cp, cpp,
find, gdb, grep, ld, ls, make, mv, rm, sed, sh and tar. When trying to run
awk (again from DOS) it (Cygwin, I guess) throws a CPU exception to do with
NTVDM, but when I run it under gdb it works fine. I'm going to attempt to
unpack the cygwin source and have a look and update of course but I'm not
that familiar with the fork code.


Elfyn McBratney
elfyn at exposure dot org dot uk

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]