This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Please help. gcc 3.2.2 configure problem or what?


----- Original Message -----
From: "Raoul Gough" <RaoulGough at yahoo dot co dot uk>
To: <cygwin at cygwin dot com>
Sent: Friday, March 28, 2003 10:58 PM
Subject: Re: Please help. gcc 3.2.2 configure problem or what?

> "Joakim Olsson" <joakim dot h dot olsson at home dot se> wrote in message
> news:007801c2f4ae$e65fa570$5510690a at jhopii400mhz dot  dot  dot 
> > Hi
> >
> > I've tried to configure and build gcc 3.2.2 under cygwin.
> >
> > the compiler builds fine but then the problem starts:
> >
> > I've tried to build fltk-1.1.3 (a gui toolkit) when I saw the
> problem.
> >
> > It seems that there are several unresolved in my new gcc.
> > I looked around and found the actual symbols in libgcc.a in the old
> gcc that
> > came with cygwin.
> >
> > What have I done wrong?


> Looks like your link command is mixing libraries from different
> versions of the compiler (why would i686-pc-cygwin gcc be looking in
> /usr/lib/mingw - maybe you're using -mno-cygwin and need a newer mingw
> library?). How about posting the output from your failing link command
> with a -v option to list the exact commands that gcc is issuing during
> the link process. Having multiple versions of the compiler installed
> can be a bit treacherous, and -v will show you exactly what it's doing
> and where it's looking.

Well I guess I messed things up a little.
Yes I think I used the new cygwin compiler to compile and link against

> >
> Are you attempting to use the cygwin compiler to build a mingw
> compiler? This is a cross-compile and I seem to remember it was pretty
> hard to get it working this way. I found it much easier to use a
> native mingw compiler to build gcc 3.2 mingw - from my experience the
> most important thing is to ensure you know what compiler is being used
> during the build process. I just renamed all the cygwin compiler
> binaries to prevent the wrong versions being accessible during the
> build.

Yes, I didn't think it was a cross-compile.

Thanks for your hints.

I'm going to give it a try again to build a new cygwin or mingw-compiler in
a day or two.

All I wanna do is to have one compiler "gcc" that at least can compile and
link programs written in C, C++, Ada and also have a gui.

So if you still think you could give hints feel free, but now I have
something I can try.

best regards
/Joakim Olsson

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]