This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug] 1.3.22-1 - rxvt & xterm displaying escape codes, cursor problems


I just upgraded my Cygwin installation on a Windows 2000 system to version
1.3.22-1. I don't remember exactly what version I was running previously.
In the previous version, xterm was functioning normally. I used the
default bash settings, which includes a $PS1 prompt variable of:
\[\033]0;\w\007 \033[32[32m\]\u at \h \[\033[33m\w\033[0m\] $

This displays correctly in the Cygwin console, and displayed correctly
under xterm in the previous installation, with color:

username at hostname directory

Now that I have upgraded, the console still displays it correctly. But,
xterm outputs the escape codes by themselves. I also tried rxvt, and it
had the same problem:

\033[32[32m\]\u at \h \[\033[33m\w\033[0m\]

I'd also like to note that I haven't been able to use 'screen' with my
Cygwin install because it gave me this same problem, even when xterm by
itself worked.

I've seen this problem crop up before, but new installations made it go
away quickly.

A second problem is with the cursor keys and backspace. Backspace simply
doesn't work. ^H does, but it backspaces over the prompt ($) is I go back
too far. The up & down cursor keys scroll my cursor around the screen
instead of recalling previous lines. The left & right cursor keys will
scroll right past the end of where I have typed, and scroll left over the
top of the prompt ($).

Any suggestions on how I can resolve this would be greatly appreciated.



Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]