This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with gawk (3.1.2-2) under Cygwin 1.3.22-1


Next time, please *attach* the output of cygcheck, as it confuses the
archive search (see <>).

Replies inline below.

On Tue, 1 Apr 2003, Jeffery B. Rancier wrote:

> Igor Pechtchanski <pechtcha at cs dot nyu dot edu> writes:
> > On Mon, 31 Mar 2003, Andrew DeFaria wrote:
> >
> >> Just installed 1.3.22-1 and I have a problem with gawk. Whenever I
> >> running it I get a Windows dialog box stating: "The procedure entry
> >> point iswlower could not be located in the dynamic link library
> >> cygwin1.dll".
> I've the same problem.  I exited my bash sessions, and ran setup from
> DOS, and rebooted.  No apparent effect, and I still get the same error
> from gawk.

setup.exe may have been unable to schedule some files for on-reboot
replacement.  See below.

> [...]
> > Sounds like a duplicate/old cygwin1.dll problem to me...  Make sure your
> > /bin/cygwin1.dll was actually replaced by setup (i.e., no Cygwin processes
> > were running while you ran setup).  A reboot should help.  If not, post
> > the output of 'cygcheck "`cygpath -w /bin/cygwin1.dll`"' (or, better yet,
> > the full 'cygcheck -svr').
> [...]
> I don't know if this is related, but running 'cygcheck -srv', I get
> the following error:
> cygcheck: dump_sysinfo: GetVolumeInformation() failed: 53

Don't know what this one means, but it's been reported by other people.
FWIW, "net helpmsg 53" shows "The network path was not found." (on Win2k).

> The remainder of the output ...
> ,----[ cygcheck.out ]
> | [snip]
> | h:\usr\pkg\cygwin\bin\id.exe output (nontsec)
> | UID: 400(jrancier)  GID: 401(mkpasswd)
> | 401(mkpasswd)
> |
> | h:\usr\pkg\cygwin\bin\id.exe output (ntsec)
> | UID: 400(jrancier)   GID: 401(mkpasswd)
> | 544(Administrators)  545(Users)
> | 401(mkpasswd)

Note the "mkpasswd" as your group name.  Please read
<>.  I don't
think this is related to your problem, but it should be fixed nonetheless.

> | [snip]
> | k:  net          N/A    N/A

I don't know for sure, but the cygcheck "error 53" above could be related
to this.

> | [snip]
> | Found: h:\usr\pkg\cygwin\bin\cat.exe
> | Found: \bin\cat.exe
> | Warning: h:\usr\pkg\cygwin\bin\cat.exe hides \bin\cat.exe

This (and other similar warnings) is weird.  Looks like you have MKS tools
(or something like that) installed in c:\bin, but it's not in the path, so
it shouldn't be here.  Not related to your problem, though.

> | [snip]
> |     Cygwin DLL version info:
> |         DLL version: 1.3.20
> | [snip]
> | cygwin                  1.3.22-1

Now, this *is* related to your problem.  Notice that you still have the
old version of the cygwin DLL (as I surmised initially), even though you
have installed the new version of the package.  I'd guess you had a cygwin
process running while updating, and something prevented setup.exe to
schedule a replace-on-reboot for cygwin1.dll.  Reinstalling the "cygwin"
package should fix this.

> | [snip]
> `----

      |\      _,,,---,,_		pechtcha at cs dot nyu dot edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor at watson dot ibm dot com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

Knowledge is an unending adventure at the edge of uncertainty.
  -- Leto II

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]