This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: apache php4 error: dlopen: Win32 error 193


The rebase that comes with the apache package is broken -- it corrupts
DLLs.  This is probably why you're seeing the problem.  Since postinstall
scripts are run by setup.exe automatically, there is no easy way to
prevent the broken rebase from running if you use setup.exe.  I can
think of a couple, but they are pretty complex.  The easier one is to
extract the postinstall script (usr/postinstall/ to some
other directory, then use "tar --delete" to remove the postinstall script
from the tarball, and then run setup.exe again to install apache (without
running the postinstall script).  Note that for the last step to work,
you'll also need to adjust the MD5 checksum for the apache tarball (in
setup.ini).  As you can see, it is by no means easy.

You can also extract the DLLs anew from the tarball by hand and have them
overwrite the rebased ones, and then use "rebaseall" from Jason Tishler's
rebase package (follow the instructions in /usr/doc/Cygwin/rebase-*README).

Ultimately, the apache package should be fixed.

On Tue, 8 Apr 2003, Javier J wrote:

> Hi!
> I am running into the same problem here.
> I have tried the classical answers:
> - re-running /etc/postinstall/ (and it _seems_ that
> it's working properly, it re-bases the dlls):
> cohen at lazarus /etc/postinstall
> $ ./
> [activating module `php4' in /etc/apache/httpd.conf]
> cp libphp4.dll /usr/lib/apache/libphp4.dll
> cp: cannot stat `libphp4.dll': No such file or directory
> apxs:Break: Command failed with rc=1
> C:\cygwin\lib\apache\libphp4.dll: new base = 67ec0000, new size = 140000
> C:\cygwin\bin\cygbz21.0.dll: new base = 67e90000, new size = 30000
> C:\cygwin\bin\cygcrypto.dll: new base = 67dd0000, new size = c0000
> C:\cygwin\bin\cygintl-1.dll: new base = 67db0000, new size = 20000
> C:\cygwin\bin\pq.dll: new base = 67da0000, new size = 20000
> C:\cygwin\bin\cygxml2-2.dll: new base = 67d00000, new size = a0000
> C:\cygwin\bin\cygz.dll: new base = 67cd0000, new size = 30000
> and then, I do:
> $ /usr/sbin/apachectl start
> Syntax error on line 238 of /etc/apache/httpd.conf:
> Cannot load /usr/lib/apache/libphp4.dll into server: dlopen: Win32 error 193
> /usr/sbin/apachectl start: httpd could not be started
> I've done some googling and it seems that Win32 error 193 means it's not
> a valid W32 image?
> Also, if I comment-out the php-related LoadModule and AddModule
> directives, and add the mod_ssl related ones, then I get another
> (hopefully, unrelated) error:
> cohen at lazarus /etc/postinstall
> $ /usr/sbin/apachectl start
> C:\cygwin\usr\sbin\httpd.exe: *** unable to remap
> C:\cygwin\bin\cygssl.dll to same address as parent(0xB10000)
>   != 0xB20000
> /usr/sbin/apachectl start: httpd could not be started
> Any ideas of _why_ this might be happening?
>         Javier
> On this day, 07/04/2003 12:08, Thomas V. Fischer wrote:
> > Hey all,
> >
> > I have tried everything in the list archive but I am still getting error 193
> > after having installed apache and php_mod.
> >
> > Rebaseall didn't work. I even reinstalled my whole cygwin installation.
> >
> > Please help!
> > Thomas

      |\      _,,,---,,_		pechtcha at cs dot nyu dot edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor at watson dot ibm dot com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

Knowledge is an unending adventure at the edge of uncertainty.
  -- Leto II

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]