This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Limited remote terminal access via cygwin]

On Fri, 11 Apr 2003, Garry Heaton wrote:

> Igor Pechtchanski wrote:
> > On Fri, 11 Apr 2003, Garry Heaton wrote:
> >
> >
> >>Reid Thompson wrote:
> >>
> >>>after you login to your remote box run one of the following commands
> >>>    export TERM=xterm
> >>>or
> >>>    export TERM=vt100
> >>>or
> >>>    export TERM='whatever term type you normally use & is recognized on
> >>>the remote system"
> >>>reid
> >>>
> >>>
> >>>>-----Original Message-----
> >>>>From: Garry Heaton [mailto:garry at heaton6 dot freeserve dot co dot uk]
> >>>>Sent: Friday, April 11, 2003 7:46 AM
> >>>>To: Cygwin
> >>>>Subject: Limited remote terminal access via cygwin
> >>>>
> >>>>I'm setting-up headless Linux/SAMBA servers for use in
> >>>>Windows office networks which I want to admin from Windows
> >>>>via Cygwin. When I 'ssh' into the Linux box from Cygwin I
> >>>>only have limited terminal access. When I try to launch emacs
> >>>>on the remote machine I get the response:
> >>>>
> >>>>emacs: Terminal type cygwin is not defined.
> >>>>
> >>>>When I examine files using 'less' I also receive the message:
> >>>>
> >>>>WARNING: terminal is not fully functional
> >>>>
> >>>>With 'less' the Cygwin/Windows terminal only displays a fixed
> >>>>% of the file examined and will not scroll to the end.
> >>>>
> >>>>My Cygwin environment settings are:
> >>>>
> >>>>ntsec check_case:strict tty
> >>>>
> >>>>Garry Heaton
> >>
> >>Tried all of these but nothing worked. I'm not running X on Cygwin. Just
> >>console mode. Still can't scroll past the first screen of an opened file.
> >>Emacs-nox also has display problems.
> >>
> >>Garry
> >
> >
> > Garry,
> >
> > TERM should reflect the terminal you're running *in* (the one you use to
> > ssh to the Windows machine).  Normally, ssh will inherit the TERM setting
> > from the invoking shell.  If something resets the TERM value (I'm guessing
> > your ~/.bashrc or ~/.bash_profile), you'll need to fix that (e.g., by
> > putting a "[ -z TERM ]" guard).
> >
> > Try invoking "bash --login -v" from ssh to see if a TERM=... command is
> > executed.
> >       Igor
> I'm not 'ssh'-ing into the Windows machine. I'm running Cygwin on the
> Windows machine to admin a Linux server. So far running emacs-nox produces
> faulty screen output. 'less' also has some problems.
> Garry

Ah, I misread it.  Sorry.

You can do one of three things:

1) Use an XTerm or an RXVT window to ssh.  That way, your TERM value will
be known on Linux.  FYI, rxvt can be used without X on Cygwin.
2) Set your TERM in the bash (command) window to something Linux will
recognize and that is compatible with the console handler (I *think*
"xterm" should work, but you'll have to try and see).  FYI, "cygwin" is
not compatible with "vt100", AFAIK.
3) Make your Linux machine understand the "cygwin" TERM value by copying
over /usr/share/terminfo/c/cygwin and the relevant part of /etc/termcap
(for older apps).

#3 is the "right way" of fixing your problem, but may be more trouble than
it's worth.
      |\      _,,,---,,_		pechtcha at cs dot nyu dot edu
ZZZzz /,`.-'`'    -.  ;-;;,_		igor at watson dot ibm dot com
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

Knowledge is an unending adventure at the edge of uncertainty.
  -- Leto II

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]