This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Cygwin driving me crazy

I am a Cygwin newbie. I used it three years ago, dropped it and 
resumed it now. This time I am enjoying it a lot, except for one 
problem that is really driving me up the walls.

It freezes at startup. In at least 5 or 6 out of every 10 times I 
launch it (Bash or ZSH), an empty window is open forever, the shell 
won't start. The only solution is to hit Ctrl+Alt+Del, kill bash or 
zsh, then kill Winoldap then try again. Sometimes I have to try again 
as many as 4, 5, 6 times until it works. I run Wintop to see what the 
heck is going on, it seems that if I call bash with the .bat file 
provided, other programs are run before, like tr and hostname, and 
sometimes one or tow of these freeze. I prefer to call bash.exe or 
zsh.exe directly, but they still freeze. I felt tempted to blame 
rxvt, but even if I don't use it and call bash or zsh directly, 
they'll freeze. Not always, but very often.

I blame Cygwin because although I didn't use Cygwin with that Unix 
directory structure all these years, I've always had many GNU tools 
in one single directory, and an old version of cygwin1.dll to 
support them. I never had this problem until a few days ago, when I 
installed almost all of Cygwin (minus graphics and devel), replacing 
all the exes and cygwin1.dll with the latest versions. I used to call 
bash.exe directly, it worked fine. Have you heard anything like that 
before? Do you even suspect what could be wrong? I'm using Win 98 SE.

Many thanks,
Luciano ES
Santos, SP - Brasil

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]