This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

shell returns


I've installed the latest cygwin incarnation and would like to be able to
execute windows commands after running a shell. Something along the line:

net use <disk letter>: \\server\share
tcsh -c <run backup shellscript here>
net use /delete <disk letter>:

I've tried both tcsh and bash, but the second net use command doesn't
execute. It does, however, if the tcsh line is commented out. bash -l -c
produces the same results. Figuring it was a return value problem, I tried
using the exit command in the shellscript that is called, but neither 0 or 1
had any effect.

Would someone please show me how to do this? It seems like it ought to work
straight away, but not in my hands. I've tried the mount command inside the
script, but couldn't get that to work either, so maybe it's something in the
way I have things installed.

All help greatly appreciated!



Ed Hoeffner
1-271 BSBE
312 Church St SE
Mpls, MN 55455
612-625-2163 fax

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]