This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Fwd: Re: CygWin adding CRs, hurting CVS client/server communications?

Quoting from the document referenced below:

  We have tried these commands but they have not quite worked for us
  mount -f -t -s c:\\cygwin\\lib /usr/lib
  mount -f -t -s c:\\cygwin\\bin /usr/bin
  mount -f -t -s c:\\cygwin /
  mount -f -t c: /cygdrive/c

The reason the commands didn't work was because the last command is just
plain wrong.  The correct command (for their purposes) would have been

  mount -c -t -s /cygdrive

after which there is no need to re-mount each drive separately (or
reinstall Cygwin).  Plus, there's a typo on that page (although in the
text that would be made redundant by the correct command above).  I didn't
find any information on the page on how to notify the maintainers of these
errors, but if anyone wants to dig deeper, it would be nice.

The above is one of the main reasons why we frown upon external

On Mon, 30 Jun 2003 wrote:

> Well, I take that back...someone pointed me to
>, which contains instructions
> for reinstalling CygWin with text mode set to DOS, which actually fixes the
> problem (the remount procedure didn't work, as is warned in the
> article).  All I did was run the setup utility, selected DOS text mode, and
> selected the base/cygwin and devel/cvs packages for
> like a charm now.  The contents of this article might be good fodder for
> the FAQs.  Cheers!
> At 08:17 AM 6/30/2003, wrote:
> >Understood.  I've compiled CVS from source on my server (which is how I
> >tracked down and confirmed the CRLF issue), but am not set up to compile
> >anything on the Windows client.  I doubt I'll have time in the near future
> >to try, so for now I'll have to ditch CVS/SSH, and once I truly need
> >version control again, either see if it's working again or go with a
> >commercial solution.  No big deal for now...thanks for trying though.
> >
> >Toscani
> >
> >At 01:55 PM 6/28/2003, Charles Wilson wrote:
> >>Sorry, guys, but I can't reproduce this.
> >>
> >>Client:
> >>
> >>openssh              3.6.1p1-2
> >>cvs                  1.11.5-1
> >>cygwin               1.3.22-1
> >>
> >>:pserver: and :ext:(CVS_RSH=ssh) mode, with server
> >>
> >>Server is running:
> >>Concurrent Versions System (CVS) 1.11.1p1 (client/server)
> >>(with local hacks)
> >>OpenSSH_3.4p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
> >>
> >>-----
> >>Because I can't reproduce this, somebody who is experiencing the problem
> >>is going to have to track it down and provide a detailed (e.g. "this code
> >>right here: "..." is wrong...) bug analysis.
> >>
> >>I can't fix what I can't see.
> >>
> >>--Chuck
> >>cvs maintainer
> >>
> >> wrote:
> >>>Forgot to CC this to the list.
> >>>
> >>>>Date: Sat, 28 Jun 2003 10:37:51 -0600
> >>>>To: "Van Rooyen G-J <>" <>
> >>>>From:
> >>>>Subject: Re: CygWin adding CRs, hurting CVS client/server communications?
> >>>>
> >>>>I've seen the same symptoms...output is garbled because CRs are left in
> >>>>the strings CVS interprets, and it spits them out after concatenating
> >>>> you wind up with lines like "textCRtextNL"...I've dumped the
> >>>>output and confirmed that this is what is happening.
> >>>>
> >>>>Another good point...I am using the CygWin CVS client, not WinCVS.
> >>>>
> >>>>Toscani
> >>>>
> >>>>At 06:49 AM 6/28/2003, you wrote:
> >>>>
> >>>>>I have exactly the same problem as Toscani describes. Last week I did
> >>>>>a routine update on my Cygwin packages, and my Cygwin CVS client
> >>>>>(which worked fine the previous day) could not authenticate with the
> >>>>>server any more. The "login" command works fine, but any subsequent
> >>>>>operations fail to authenticate. Furthermore, the server error message
> >>>>>is garbled, as if a CR/LF problem occurred.
> >>>>>
> >>>>>Client: Cygwin on WinXP
> >>>>>
> >>>>>Server: Redhat (not sure of the version)
> >>>>>
> >>>>>Authentication: Plain pserver, no SSH.
> >>>>>
> >>>>>Judging from Patrick's response (who uses WinCVS, and not Cygwin CVS)
> >>>>>the problem lies somewhere in the Cygwin CVS client, not in Cygwin SSH.
> >>>>>
> >>>>>G-J
> >>>>>
> >>>>>
> >>>>>--- in response to: ---
> >>>>>
> >>>>>Works like a charm here, both for binmode and textmode mounts.
> >>>>>My system: Win2k, WinCVS and Cygwin SSH
> >>>>>The problem mentioned in your mailing list reference was fixed long
> >>>>>time ago.
> >>>>>Do your line endings change as well if you scp a textfile from your
> >>>>>client to your server? If yes, then we have indeed an ssh issue on
> >>>>>WinXP platforms. Otherwise your problem must lie somewhere else.
> >>>>>
> >>>>>Patrick
> >>>>>
> >>>>>
> >>>>>--- in response to: ---
> >>>>>
> >>>>>Hey folx...currently using OpenSSH under CygWin on an XP box to
> >>>>>communicate with a CVS server on a Linux box. Recently upgraded my
> >>>>>CygWin installation (1.3.22(0.78/3/2), including OpenSSH to v3.6.1p1
> >>>>>(the latest available under CygWin), and now CVS client/server
> >>>>>communications over SSH (CVS_RSH=ssh) don't work.
> >>>>>I've tracked the problem deep enough to suspect that SOMETHING in
> >>>>>CygWin converts LF to CR+LF line terminators across SSH. This pretty
> >>>>>much hoses CVS client/server communications, as the CVS server
> >>>>>interprets all incoming lines as byte strings including a CR at the
> >>>>>end (it treats LF as the actual terminator)...especially bad for
> >>>>>pathname interpretation, but lots of other things may be affected as
> >>>>>well. I've tried altering the CVS server code to eat the extra CRs,
> >>>>>but too many other things break (including file data exchange I'd
> >>>>>bet...can't tell which CRs are valid data and which are inserted by
> >>>>>the system) for that to be effective.
> >>>>>Found a reference in the mailing list archives to a similar problem
> >>>>>someone was having last October, but the solution was to install a
> >>>>>snapshot from that time period which seems to be no longer available.
> >>>>>I'm wondering if the fix for this issue never found its way into more
> >>>>>recent versions of the CygWin system components? I've upgraded CVS on
> >>>>>both client and server, but based on my testing, I don't think CVS
> >>>>>itself is adding the CRs...please flame if I'm wrong on that one. <g>
> >>>>>Not sure what else to do right now but do without version control for
> >>>>>a bit...any better ideas?
> >>>>>- Toscani

      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"I have since come to realize that being between your mentor and his route
to the bathroom is a major career booster."  -- Patrick Naughton

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]