This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: bug in setup.exe for postgresql-7.3.4-1

Jason Tishler wrote:
> On Mon, Aug 04, 2003 at 12:25:43AM +0100, Max Bowsher wrote:
>> Seth Rubin wrote:
>>> Myself (and Jason) are thinking there's an issue with the cygwin
>>> setup.  Maybe I'm being naive, but all this seems is an issue with
>>> chmod and/or copy not being done properly on the postgres.exe file
>>> during installation.  I don't see where ACL's or ntsec enters into
>>> it.
>> Here's how:
>> Cygwin setup *doesn't* chmod anything at all.  Hence, the file
>> permissions end up being set by normal Windows inheritance.  Now,
>> interpret that through ntsec, and you end up with mode 700 - on your
>> particular system. Setup does try to help things to turn out right, by
>> setting the group to Users, on the grounds that most systems will
>> grant Users at least Read&Execute, and most users will be in group
>> Users. That apparently doesn't hold true on your setup, hence your
>> problems.
> Is there any way to solve this problem without me adding a postinstall
> script that performs a "chmod +rx" on all *.exe and *.dll files
> installed by this packages?

Yes. PTC for setup.
Please please please don't add this kind of postinstall script.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]