This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with pthreads and signaling, behavior broken...

Btw, if someone can figure out precisely what they think is going wrong
with the ostensible problems that people are reporting, I'll be happy to
track this down.

I don't mean vagueness like "I think the signal isn't going to the
thread".  I mean something concrete like "The signal handler is not
returning correctly to the calling thread, because..." or "The
keepRunning variable is not getting set".

It seems like if someone is seeing problems they could be sending some
debugging output to a file or something to help track the problems down.
You know?  Debugging 101?

I always try to fix problems that I can duplicate but I'm not going to
spend an inordinate amount of time trying to fix problems that I can't
duplicate in something that is so clearly a corner case.  I can see that
ThreadTest is supposed to be creating a bunch of threads but, beyond
that, I'm not interested in learning its intricacies.

I just tried this on one more system and it got a SIGSEGV no matter what
version of the Cygwin DLL I used.  The difference with this system is
that it is multi-processor (it's also running XP, FWIW).  From the gdb
stack trace, it seems like the problem may be because some operation
which manipulates a global list is not properly thread safe but, like I
said, I really don't want to delve into the mysteries of this program so
I didn't debug it very thoroughly.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]