This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

AW: Inaccessible remote volumes when logged in via ssh

I am logging in using password (i already heard of troubles using
publickey, altough i can log in as normal user using public key)
The volume is mounted using the explorer menu (extra -> connect drive, i
dont know if thats correct because i have a german version), and it is
configured to mount automatically at startup.

I just tried to use "net use" in my ssh-session and noticed it doesnt
work (system error 1312)
It is the same case as in
And in


It has something to do with user-privileges and that the sshd runs as
user SYSTEM. It seems, that the ssh-sessions also runs as SYSTEM, and
not as user which logged in.

What i dont understand is, why it works when i log in locally via ssh
(ssh localhost -l bpc). It should also run as user system without

I tried the following:
At <current-time + 1> /INTERACTIVE cmd

Which should open a cmd-shell in one minute which runs as SYSTEM.
The shell opens and i also have no access to the network.

So i tried to start the sshd service as user "sshd" (changed owner of
all files, adjusted the security policies etc). The service starts but
the strange result is, that i cant login with password anymore, only
with public key !!! And i still dont have acces to network .
When i do a ps -W -f i get:

    sshd    1608       1   ?  14:10:21 /usr/bin/cygrunsrv
    sshd    1348    1720   ?  14:11:09 /usr/sbin/sshd
       0     756       0   ?  14:11:11 C:\cygwin\bin\bash.exe
     bpc    1716    1680   1  14:11:46 /usr/bin/ps
       0    1760       0   ?  14:11:47 C:\cygwin\bin\ps.exe

So i assume, the shell still run under SYSTEM account

Trying around with UsePrivilegeSeperation i had trouble starting the
service at all. (complained about wrong privileges of /var/empty)


-----Ursprüngliche Nachricht-----
Von: Joshua Daniel Franklin [] 
Gesendet: Montag, 10. Mai 2004 22:21
Betreff: Re: Inaccessible remote volumes when logged in via ssh

On Mon, 10 May 2004 22:50:27 +0200, Brindl Ronald <>
> Sshd is running as local system,

Are you logging in with a password or publickey?

Are you using the 'net use' command?

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]