This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Clapack on Cygwin


I tried to install clapack on cygwin and errors occurred. I would very much
appreciate your help.

In particular:

I downloaded clapack.tgz from, unpacked it
with WinRAR and followed steps 1-5 of the clapack readme.install
successfully. I used the instead of the default
(after renaming it to I did not
change the platform (PLAT in specification to _Cygwin. I left it
as it was: _Linux. On step 6 of the readme.install instructions I did:

cd clapack/testing/matgen and then make, which worked fine. Then I did
cd clapack/testing and then make. Things seemed to proceed without errors
until I got the following message:

NEP: Testing Non Symmetric Eigenvalue Problem Routines
./xeigtsts < > snep.out 2 > & 1
signal 11
make: *** [snep.out]
Error 139

The process underway stopped. I inspected all the *.out files that I could
find. The stest.out was without errors (I suppose this was referring to the
first step). The snep.out was empty which could be because of this
interruption due to that error that occurred.

I tried to reproduce that problem and everytime I tried I was getting a new
error message until I got no errors at seemed as if the error was
going down from snep.out to dnep.out to cnep.out until it could no longer
find any *nep.out files to affect...

So, I thought step 6 is past me and continued with step 7. I went into the
clapack/timing directory and typed make. Things seemed to run forever. Thus,
./xlintimc < > ctime.out 2> &1 (what I am attempting now) is up on
the screen for more than 20 min...Initially, I had a problem with ./xlintims
< > stime.out 2>&1 but somehow re-running the make command solved
(?) the problem (as before). So, now I got stuck with the complex routines
and if I overcome this I suspect I will get an error with the double
precision routines...

As I was searching for clues over the internet, I found a suggestion which
was saying that if things run forever with the timing of the clapack
routines, this could be due to a faulty sprintf command. I added the
recommended line- cure into the appropriate file but things did not seem to
speed up.

How can I make the process of timing the clapack routines run in a
reasonably finite amount of time?

(I am running all the make commands after I do startx on bash)

I hope that my way of posing the problem is descriptive enough..:)

I would be grateful of your help.



Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]