This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

PostgreSQL: Bad system call

Hi all,

once again I've hosed my PostgreSQL installation. I've more or less accidentally
upgraded PostgreSQL to the latest version and it would start no more. I've
perused the archives and collected all remedies I've found. Most notably:

- I had fixed the / and /bin permissions previously and made sure they're still
- I made my postgres user account own the binary
- I've removed the cygipc and cygipc2 services
- I've installed cygserver and made sure it is actually started
- Needless to say, I've rebooted the box too

No matter what I do, I'm now stuck with the following error. For test purposes I
logged in to my postgres account and started postmaster manually with
postmaster -d5 -D /usr/share/postgresql/data

[lots of DEBUG messages]
DEBUG:  invoking IpcMemoryCreate(size=10461184)
Bad system call

As I got stuck here I desperately tried various things, among them removing
cygserver and starting cygipc2 again and downgrading to the previous PostgreSQL
version. All this does not help a bit. I've not yet tried to downgrade
cygwin1.dll to the previous version (1.5.11 vs. 1.5.12).

Can anyone throw me a ring here?


Markus Hoenicka
(Spam-protected email: replace the quadrupeds with "mhoenicka")

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]