This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: running a DOS batch file from a shell script - script doesn't wait for batch file to complete before continuing

I guess I should have been more specific with my original posting...

I was running pro_batch in command-line mode (pro_batch -text ...) and not
interactive mode, i.e. not using the GUI at all. I thought it was implied since
I was talking about running a shell script and a batch file. The shell script
actually constructs the command-line and input file automatically and then
kicks off the DOS batch file. The script is supposed to monitor to contents
of the file pro_batch.log.1 afterwards but it started to parse the file contents
even before the DOS batch file is completed. If I forced a long wait by adding
a "sleep 300" after the DOS batch file command, parsing was done properly.
However, I cannot set a fix wait time as it depends on the complexity of the
Pro/E assembly.

You are correct in that the pro_batch interactive mode does work.


At 22:26 12/09/04 -0500, you wrote:
At 09:55 PM 12/9/2004, you wrote:
>I have a shell script (#!/bin/sh) that runs a DOS batch file. During the execution of the shell script,
>it runs the DOS batch file (Pro/ENGINEER's PRO_BATCH.BAT to generate a plot file) but the
>script does not appear to wait for the DOS batch file to finish first before continuing.
>I tried running the DOS batch file using another shell (/bin/sh -c file.bat) within the script,
>use "wait" right after the batch file line to wait for the process to complete first but none of
>them seem to work. I've also searched the web for answers with no avail. It looks like
>once the DOS batch file starts to execute, it is not possible to exercise job control on the
>cygwin unix side. The versions of my Cygwin and Windows are:
>Cygwin version: CYGWIN_NT-5.1 1.5.9 (0.112/4/2)
>OS version: Windows XP Professional Version 2002 w/ Service Pack 1

The following worked fine for me:


This is with the latest Cygwin (1.5.12) and W2K.

The version of Pro/E is a bit out of date but it still popped up the GUI
and sat there waiting for me to do something.  The shell script didn't
exit until I terminated the program/bat file.


-- Larry Hall RFK Partners, Inc. (508) 893-9779 - RFK Office 838 Washington Street (508) 893-9889 - FAX Holliston, MA 01746

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]